OUYA

52 replies to this topic
Posted 11 months ago #51
AdamRedwoods

re:invalid target

i usually have to put the target in quotes when using the command line.
-target="C++ Tool"
the target is case sensitive, and you may need spaces.

 
Posted 11 months ago #52
Sensei

Thanks Adam! Will keep that in mind for future.

 
Posted 11 months ago #53
computercoder

The reason it worked and the OUYA CE version did not is due to the fact you HAD Android target running. Mark's version uses "android" as the build system, but defines a new target name to the target called "Android (Ouya) Game"

Notice the android target "TARGET.MONKEY":

#TARGET_NAME="Android Game"
#TARGET_SYSTEM="android"
#TARGET_BUILDER="android"

And here's the android_ouya target "TARGET.MONKEY"

#TARGET_NAME="Android (Ouya) Game"
#TARGET_SYSTEM="android"
#TARGET_BUILDER="android"

The compiler knows which you are pointing at by the name. The fact they are in two separate folders allows the IDE to detect them as different targets.

Since you never successfully compiled transcc with the new "ouya" target type, it could NOT determine it existed even with the folder being in the targets folder.

Had you changed the "ouya" target "TARGET.MONKEY from:

#TARGET_NAME="Ouya Game"
#TARGET_SYSTEM="android"
#TARGET_BUILDER="ouya"

To the following:

#TARGET_NAME="Ouya Game"
#TARGET_SYSTEM="android"
#TARGET_BUILDER="android"

It would have just piggy-backed off the android builder already compiled into transcc. :)

I've played around with this target quite a bit and then just flat-out tried doing the changes above. I realized that since OUYA is based on the droid anyways, it should just work. In 75b I did try to do that, and watched it work. So realistically, you do not need to recompile the transcc. You do need to follow everything else to get the Android target running. Keep in mind that with OUYA, you need version 16 of the SDK. Just follow the OUYA installation instruction on their developer site to get everything set is the only extra step for OUYA above Android - and they even show you how to setup for the SDK to Android :)

I hope this helps!